VLAN Trunking Between Nexus 5010 and Dell PowerConnect Switches

If you don’t work in the networking space on a regular basis, it’s easy to overlook interoperability issues between equipment from different vendors. After all, a VLAN trunk is a VLAN trunk is a VLAN trunk, right? Alas, the answer is not always quite so simple.

While standards such as 802.1Q promise easy interoperability, the devil is usually in the details. I ran into just this sort of problem today in the lab. Specifically, I had a need to trunk VLANs between a pair of Cisco Nexus 5010 switches and a pair of Dell PowerConnect 6248 switches.

The configuration on the Cisco Nexus side was pretty straightforward (note that this was one of the first eight ports on the switch and was throttled down to 1Gbps):

interface ethernet 1/1
  switchport mode trunk
  speed 1000

I tried replicating this same setup on the PowerConnect switches using Dell’s switchport mode trunk command. Unfortunately, it didn’t work. I kept digging around, but regardless of the configuration the show interfaces switchport ethernet command would always show that VLAN 1 was marked as tagged. This clearly wouldn’t work; since VLAN 1 was defined as the native VLAN on the Cisco Nexus switch, it would be untagged on the Cisco side. I needed the VLAN to be untagged on the Dell side as well.

Quite by accident, I stumbled upon a slightly different command on the Dell: the switchport mode general command. The help text in the interface indicated that this was the correct configuration for 802.1Q operation.

I modified the Dell PowerConnect to use this configuration:

interface ethernet 1/g47
switchport mode general
switchport general allowed vlan add 1 untagged
switchport general allowed vlan add 900 tagged

With this configuration, the show interfaces switchport ethernet command now reported that VLAN 1 was untagged, as shown in the screenshot below.

A quick connectivity test showed that traffic was now flowing properly between the Dell PowerConnect 6248 switches and the Cisco Nexus 5010 switches. Problem resolved! Key takeaway: use switchport mode general for interoperability with other vendors’ switches.

If you have any experience with Dell PowerConnect switches and have additional information to share, please post it in the comments below.

Tags: , ,

  1. Brad Hedlund’s avatar

    Scott,
    Nice find the Dell command. Another possible solution would be to configure the Nexus 5000 to tag the native VLAN – thereby tagging all VLANs on the port.

    The command to do this on Nexus 5000 is ‘vlan dot1q tag native’
    Its a global setting affecting all trunk ports

  2. slowe’s avatar

    Brad, I thought about configuring the Nexus to tag the native VLAN, but I was concerned about what other impacts it might have ha don the network. Thanks for pointing that out, though!

  3. matt’s avatar

    seriously, who the h*** uses vlan 1 in the first place? Every trunk should explicitly specify allowed vlans !=1. You caused your own problem by being silly.

  4. Toan Pham’s avatar

    I do have completed setup between Dell PC6224 and PC8220 on Dell Chassis M1000e to Cisco Nexus 5000 in our environment. If you’re interested, I can post the graphic document. The configuration works for all Windows, Linux, and VM running on Blades with multiple VLANs in Trunk mode and Access mode.

  5. Pete’s avatar

    What then is the true distinction between trunk and general as it relates the the powerconnect switches? I’ve seen a number of configs on both the 54xx and the 62xx series that appear to use them both. The configs I reworked from scratch (demonstrated here http://itforme.wordpress.com/2011/06/26/reworking-my-powerconnect-6200-switches-for-my-iscsi-san/ ) were with the help of dell and EQL. Now I have some 5424s that I have to LAG, and hope to make the right choice the first time.

  6. Rosa’s avatar

    What does it mean ?
    (note that this was one of the first eight ports on the switch and was throttled down to 1Gbps)
    Configuration must be done on the first port ? Speed 1000 only ?

    I am having trouble trying a spf connection between a Cisco NEXUS 7000 and a DELL 6224.

    NEXUS 7000 is a VTP server and DELL should inherit (maybe recognise only) a Cisco vlan id.

    My unsuccessful :
    1. I have started with ethernet ports on booth sides;

    2. I have created a vlan id=6 on Dell;
    configure
    vlan database
    vlan 6
    exit

    3. DELL 6224 port config
    configure
    interface ethernet 1/g1
    switchport general allowed vlan add 6
    exit

    4. NEXUS 7000 is running Server VTP Operating Mode, VTP V2 Mode
    interface Vlan6
    no shutdown
    description vlan test
    ip access-group vlan vlan6_access_in in
    ip access-group vlan6_access_out out
    ip address 17.35.6.200/24
    4. NEXUS 7000 port config:
    interface Ethernet10/26
    description Teste DELL 6224
    switchport access vlan 6
    no shutdown

    5. I have connected tp cable on DELL eth 1/g1
    6. I have connected tp cable on NEXUS eth 10/26

    Result:
    Vlan id=6 on NEXUS was automatically removed

    Second test (successful):
    CISCO NEXUS7000
    interface Ethernet10/26
    description Teste DELL 6224
    switchport access vlan 6
    no shutdown

    But … what should I do when sfps must be used (10G) ?

    DELL 6224 as dumb sweetch
    factory configuration

  7. David Pasek’s avatar

    DISCLAIMER: I work for DELL Professional Services Organization.

    PCT 6224 is quite old (not bad – good price/support) gear and therefore obsolete switch with firmware 3.x … CLI in this firmware is quite different then CISCO de facto CLI standard. The main difference is with switchport modes philosophy (access, trunk, general). It changed with firmware 4.x where CLI is in more CISCO like style (access,trunk + native vlan). But PC6224 unfortunately cannot be upgraded to 4.x. That’s differs with blade switches PCT M6220 where firmware can be upgraded to 4.x

    However even in 4.x firmware there are still some differences you have to be care of.

    PCT 6224 hardware replacement is PCT 7000 (1G switch with firmware 4.x and above), PCT 8000 (10G with firmware 4.x and above) or Force10 models (FTOS) ;-)

    Scott I understand that this is your lab – i have PCT6200 switches in my lab as well – but to be honest PCT switches are positioned to SMB/Midrange and if someone have enterprise environment with CISCO NEXUSes in core then Force 10 in access is definitely better choice.

    For more info about powerconnects history and future look at
    http://en.wikipedia.org/wiki/Dell_PowerConnect

    Anyway thanks for this blog post because I’ve seen lot of networking people (CISCO admins) fighting with the same issue and I explain them exactly what you are describing here ;-)

    Really appreciate your continuous publishing effort and sharing your knowledge.

    David.

Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>