Connecting Nexus 5000 to Older Gigabit Ethernet Switches

One of the things that confused me when I first started working with the Nexus 5000 line was how I would connect this 10Gb Ethernet switch to older 1Gb Ethernet switches, like the older Cisco Catalyst or HP ProCurve switches that I also have in the lab. It turns out—many of you probably already know this—that the first 8 ports on a Nexus 5010 and the first 16 ports on Nexus 5020 can be configured to operate as Gigabit Ethernet ports. You can use these ports to connect to older Gigabit Ethernet switches.

It’s really not too complicated. In this post, I’ll describe the configuration I used to connect a Cisco Catalyst 3560G and an HP ProCurve 2924 to a Cisco Nexus 5010. In both cases, I used a 2-port port channel to link the switches together. The one drawback is that the Nexus doesn’t participate in VTP, so all VLANs have to be manually defined on each switch independently. For my small lab environment, that’s not a showstopper, but it does underscore the fact the Nexus 5000 series is primarily target as access switches.

Here’s the configuration I used on the Nexus:

interface Ethernet1/3
switchport mode trunk
speed 1000
switchport trunk native vlan 999
channel-group 3 mode on

This configuration was repeated on 2 ports for the Cisco Catalyst 3560G and on 2 more ports for the HP ProCurve 2924. Obviously, each of them used a different port channel (channel-group 3 mode on for the Catalyst and channel-group 4 mode on for the ProCurve). Remember that you have to use one of the first 8 (for a Nexus 5010) or the first 16 (for a Nexus 5020) ports because these are the only ports that support setting the speed down to Gigabit Ethernet.

On the Cisco Catalyst 3560G, the configuration is almost identical:

interface GigabitEthernet1/10
switchport mode trunk
switchport trunk native vlan 999
channel-group 2 mode on

This configuration is repeated on two ports (same as the Nexus). Note that the channel-groups don’t have to match between the switches, only within each switch. There’s no need to specify the speed here on the Catalyst, as this is already a Gigabit Ethernet port. We only need to specify the speed on the Nexus because it won’t negotiate down to Gigabit Ethernet.

On the HP ProCurve, the configuration is pretty understandable. First, the trunk command creates the port channel:

trunk 23-24 Trk1 trunk

Then, the VLAN configuration specifies the same native (untagged) VLAN on the port channel:

vlan 999
name "Trunk-Native"
untagged 12,14,20,A2,Trk1
no ip address
exit

Once the configuration is done, you’ll need to insert RJ-45 SFPs (Cisco product number GLC-T, I believe) into the appropriate ports on the Nexus 5000 switch and then cable the switches together. If you didn’t make any typos along the way, then you should be good to go!

Tags: , , ,

  1. DS45’s avatar

    Thank you for your post.
    Yes Scott, FCOE and Nexus 5000 are not geek’s technologies.

    Howto (for french people) : http://ds45.blogspot.com/2009/08/howto-quest-ce-que-le-nexus-5000-en.html

    What i did ?

    - 2 nexus 5010 + FC with 2 Pillar Data Axiom 500 connected in FC4.
    - Replication with 2 FalconStor IPSTOR.
    - 2 vSphere (2×3 hosts) Farm connected with Emulex CNA. I stopped SRM because as you know, it’s actually supported on vSphere. The network is 19 Km large …..it’s in production since june not a lab.

    Have a nice day.

  2. Jeremy L. Gaddis’s avatar

    “The one drawback is that the Nexus doesn’t participate in VTP, so all VLANs have to be manually defined on each switch independently.”

    That’s not a drawback. Nobody in their right mind uses VTP anyway. :P

  3. GNijs’s avatar

    Nice article. However, i wonder: could you also connect a classic switch across two N5000 using vPC ? Should work i guess……

  4. Justin Campbell’s avatar

    I use VTP… I have 40-some switches to manage, why wouldn’t I?

  5. Ben’s avatar

    Is it possible to connect Nexus 5000 to a old model non-managed 1000Base-T ethernet switch like D-Link DGS-1008T, that has no VLAN support? Thanks.

  6. slowe’s avatar

    Ben,

    It’s possible, although you’d probably have to mess around with the native VLAN (the untagged VLAN) on the Nexus 5000. This will help with interoperability between the Nexus and switches that don’t support VLANs. This is just a guess, though—I’ve never actually done it.

  7. Paul’s avatar

    DOes anybody have any articles like the one above to connect a NExus 5020 to a Catalyst 6500.

    Any help will be much appreciated.

  8. Fabian Bader’s avatar

    @Paul:
    I don’t know an article the configuration looks like the configuration below. We have a two 6500 connected with VSS connected to two Nexus 5020 but I reduced it to a one and one connection in the example.
    On the 6500:
    interface Port-channel10
    description 6500-Nexus5020
    switchport
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1-4094
    switchport mode trunk
    !
    interface TenGigabitEthernet1/4/3
    description 6500-Nexus5020
    switchport
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan1-4094
    switchport mode trunk
    channel-group 10 mode active
    !
    interface TenGigabitEthernet1/4/3
    description 6500-Nexus5020
    switchport
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1-4094
    switchport mode trunk
    channel-group 10 mode active

    Nexus 5020:
    interface port-channel10
    description Nexus5020-6500
    switchport mode trunk
    vpc 10
    speed 10000
    !
    interface Ethernet1/18
    description Nexus5020-6500
    switchport mode trunk
    channel-group 10 mode active
    !
    interface Ethernet1/19
    description Nexus5020-6500
    switchport mode trunk
    channel-group 10 mode active

    Don’t forget to configure the VLANs on the 5020

  9. nicky’s avatar

    donno if this discussion is still open .. but does anyone know if it also possible to connect a 1 gig port of the fabric extender (2248TP) to a 3560 switch that is not configured as a trunk .. ?

  10. slowe’s avatar

    Nicky,

    To my knowledge, you can only connect fabric extenders to supported Nexus 5000 (and soon Nexus 7000) switches.

  11. robert_r’s avatar

    yes you can

  12. Thomas’s avatar

    Trying to connect HP5800IRF 10GB port to Nexus 5548 10GB using Twin-ax.
    cmd: channel-group 300 mode active
    Error Msg: command failed: port not compatible [Members should have same fex config].
    Any help on this would be great.
    Thanks

  13. Juan Carlos’s avatar

    Hi.
    I´m conecting a C6500 with a N5k wit a FO SM. I put the ports in routed mode to test the link, but when i send ICMP packet the delay is 10 ms (in both directions).
    I did the same test but with a C3750 in place of N5k (with the same SFP) and the delay is 1 ms.
    Both ports are configured with speed 1000 and dúplex full.
    Do I need same aditional configuration in N5K ?
    why is the diference in the delay ?